Een bug in Samba, een veelgebruikt Linux-programma, brengt volgens beveiligingsspecialisten evenveel gevaar met zich mee als de Wannacry-worm.


Hoe heeft technologie een impact op je business?
Ontvang elke week het zakelijk IT-nieuws rechtstreeks in je inbox!



 
Beveiligingsspecialisten hebben een bug gevonden in Samba, een applicatie die op veel Linux-systemen wordt gebruikt. Het lek bevindt zich sinds 2010 in Samba en laat cybercriminelen toe om kattenkwaad uit te halen na slechts één lijn code te hebben uitgevoerd. De experts maken de vergelijking met de bug in Windows die de Wannacry-worm misbruikte.

Networkingfuncties

Samba is een programma die vaak standaard op Linux-systemen wordt geleverd. De software werd in 1991 geïntroduceerd om Linux- en Unix-gebruikers de kans te geven om bestanden, printers en andere middelen te delen. Samba zorgt ervoor dat Unix- en Linux-machines kunnen samenwerken met Windows-networkingfuncties, zoals Active Directory en Windows Server Domain. De bug die werd ontdekt, bevindt zich in Samba sinds versie 3.5, die in 2010 werd uitgerold.
 
Hackers kunnen enkel misbruik maken van het lek wanneer poort 445 voor bestand- en printerdeelfuncties bereikbaar is van het internet. Bovendien moeten gedeelde bestanden geconfigureerd zijn om schrijfrechten te hebben en moeten deze bestanden gekende of eenvoudig te raden serverpaden gebruiken. Indien aan deze voorwaarden is voldaan, kunnen cybercriminelen code uploaden en ervoor zorgen dat de server deze uitvoert.

Kwetsbare systemen

Rapid7 voerde een onderzoek uit om na te gaan hoeveel systemen gevaar lopen. Volgens de beveiligingsspecialist zijn er 104.000 toestellen die aan het internet zijn blootgesteld via poort 445 en een kwetsbare versie van Samba gebruiken. Van de 104.000 systemen gebruikt maar liefst 90 procent een versie van Samba waarvoor niet meteen een patch beschikbaar is.

Oplossing

De makers van Samba hebben een bericht gedeeld waarin ze het gevaar van de bug uitleggen en een workaround aanbieden. Ook hebben de makers een patch klaar voor Samba versie 4.63, 4.5.9 en 4.4.13. Wie een oudere versie van Samba gebruikt, wordt aangeraden de workaround te gebruiken. Voeg de parameter nt pipe support = no toe aan de global-sectie van het configuratiebestand van Samba (smb.conf). Herstart hierna de SMB-daemon. Sommige functies van Samba zullen hierna jammer genoeg niet meer werken.

LAAT EEN REACTIE ACHTER

Please enter your comment!
Please enter your name here